Sunday, 20 January 2013

Unix for the DBA

1) How many Oracle instances running on OS
ps -aef | grep pmon

2) Seting unix Prompt.
export PS1="`hostname`:$ORACLE_SID:$PWD>"

3) Useful commands in Aix/Linux/Solaris.



Category
AIX
LINUX
Solaris
CPU
vmstat 1, prtconf,   lsdev -Cc processor
cat /proc/cpuinfo
psrinfo -v
RAM
prtconf
free -m
prtconf | head -3 |grep Mem
Swap
lsps -a
free -m
swap -l
RPM/Package Installation Check
lslpp -L | grep <package name>
rpm -qa
pkginfo
Error logs
alog -o -t boot, errpt
dmesg
dmesg
Performance monitor
topas, nmon
top
top
Network parameters
no -a
sysctl -a | grep net
ndd /dev/[tcp|ip]
List physical volume
lspv
pvdisplay
vxprint -dl
List logical volume
lslv
lvdisplay
vxprint -vl
Startup script
/etc/rc
/etc/rc.d/rc
/etc/init.d
Kernel Parameters
lsattr -E -l sys0
sysctl -a
sysdef -i






























































































Good Sites for Oracle DBA

Below are very good Oracle DBA site one can use to improve DBA skill.

http://www.idevelopment.info
http://www.oracle-base.com
http://www.akadia.com


Campare various RDBMS
https://en.m.wikipedia.org/wiki/Comparison_of_relational_database_management_systems

Oracle and MSSQL
-------------------------------
https://www.mssqltips.com/sqlservertip/3597/comparison-of-sql-server-and-oracle-terminology/


For various oracle issue, solution with good discussion, One can follow Thomas Kyte's site a renowned Oracle expert.
Oracle forum is also a very good source, which cover various topics across Oracle database and tools etc.

http://www.akadia.com
https://forums.oracle.com/
http://asktom.oracle.com/
https://support.oracle.com/   But its not free, Official site for Oracle's customer.

 


Saturday, 19 January 2013

How to get Oracle DBA Job as Fresher

Well, most of the companies looks for experienced DBA to handle their companies databases for obvious reason, Db's are important part of any application, without backend, no application can completes.

So rather wasting time for first start, if you decided and wanted start carrier as Oracle DBA (other DBA carries too e.g. Sybase/MS-SQL)  after completion of their degree. I would recommend them to do one good Oracle DBA training. Trainer should be someone who is experienced DBA, so that he can share his experience of fixing issues in training not just command and theory. Get OCP certification completed, even though certification was never been selection criteria for most of the company, but It add some value to your resume.

As fresher one will struggle to get change as Oracle DBA, so he has to start with some Oracle DBA related work e.g. Audit log review jobs, DML/DDL deployment jobs etc. Get Oracle installed in their  PC's and start practicing on issue (emulated issue). Companies in India recruit fresher as Oracle DBA to offer services to their client in US/UK, even India etc. Fresher may not get actual DBA work immediately but gradually he can get hold on DBA related day to day activities. Responsible DBA task comes to your way when you have that much aptitude, knowledge and the confidence.

If you know PL/SQL, SQL,OS knowledge (IO/CPU related info) and Unix shell scripting  (Linux/Aix etc.) will add  feather to your cap. It's optional but really add value in your work. In long term you  have to customized, developed and troubleshoot the Linux scripts.


Few more tips....
1)  Most of time Interviewer ask scenario based questions to differentiate actual experience and non experienced or fake experience.
2)  Always practice and emulate the scenario and work on troubleshoot. Root cause identification is very important for every Issue/Problem in PROD environments. Also for your own learning.
3) There are many good blogs, forum and websites you can get those problems and solutions.
4) support.oracle.com is paid site but very good source of problem and solution.
5) One of best site is www.oracle-base.com is free site, which has ample information about Oracle DBA and related info.
6) There are many youtube videos available now a days, which can give lot of information.

All the Best guys !! I hope this helpful.

Thanks.